Confidential Information

Published by
NVIDIA Corporation
2701 San Tomas Expressway
Santa Clara, CA 95050

Copyright © 2001 NVIDIA Corporation. All rights reserved.

This software may not, in whole or in part, be copied through any means, mechanical, electromechanical, or otherwise, without the express permission of NVIDIA Corporation.

Information furnished is believed to be accurate and reliable. However, NVIDIA assumes no responsibility for the consequences of use of such information nor for any infringement of patents or other rights of third parties, which may result from its use. No License is granted by implication or otherwise under any patent or patent rights of NVIDIA Corporation.

Specifications mentioned in the software are subject to change without notice.

NVIDIA Corporation products are not authorized for use as critical components in life support devices or systems without express written approval of NVIDIA Corporation.

NVIDIA, the NVIDIA logo, GeForce3, GeForce, GeForce2 Ultra, GeForce2 MX, GeForce2 GTS, GeForce 256, Quadro2, NVIDIA Quadro2, Quadro2 Pro, Quadro2 MXR, Quadro, NVIDIA Quadro, Vanta, NVIDIA Vanta, TNT2, NVIDIA TNT2, TNT, NVIDIA TNT, RIVA, NVIDIA RIVA, NVIDIA RIVA 128ZX, and NVIDIA RIVA 128 are registered trademarks or trademarks of NVIDIA Corporation in the United States and/or other countries.

Intel and Pentium are registered trademarks of Intel.

Microsoft, Windows, Windows NT, Direct3D, DirectDraw, and DirectX are registered trademarks of Microsoft Corporation.

CDRS is a trademark and Pro/ENGINEER is a registered trademark of Parametric Technology Corporation.

OpenGL is a registered trademark of Silicon Graphics Inc.

SPECglperf and SPECviewperf are trademarks of the Standard Performance Evaluation Corporation.

Other company and product names may be trademarks or registered trademarks of the respective owners with which they are associated.
Table of Contents

1. Introduction to the NVIDIA 3D Stereo Driver
   About the NVIDIA 3D Stereo Driver ........................................... 1
   How the Driver Works .......................................................... 1
   Driver Features ................................................................. 1
   New Features in the 3D Stereo Driver for Detonator XP ................. 2
   System Requirements .......................................................... 4
   Safety - Read Before Using! .................................................. 5
   Maximizing Safe Use .......................................................... 5
   Epilepsy ............................................................................. 6

2. Using the NVIDIA 3D Stereo Driver
   Getting Started ................................................................. 8
   Step 1: Install the Drivers and the Stereo Viewing Hardware ........ 9
   Step 2: Set Up the Stereo Type .............................................. 10
   Step 3: Enable the Stereo Function ....................................... 10
   Step 4: Set Up Basic Stereo Parameters .................................. 13
   Step 5: Play Games in Stereo ............................................... 16
   Game Ratings for Stereo ...................................................... 17
   Understanding the Game Ratings ........................................... 17
   Viewing the Game Ratings .................................................... 17
   Stereo Test and Refresh Rate Setup ...................................... 18
   Controlling the Refresh Rate ............................................... 18
   Testing Display Combinations ............................................. 20
   3D Stereo Laser Sight ......................................................... 21

3. Using the Game Configuration Feature
   The Purpose of Game Configurations ..................................... 23
   Characteristics of Good Stereo Viewing .................................. 23
   What the NVIDIA 3D Stereo Driver Provides ......................... 23
   Creating and Modifying Game Configurations ......................... 24
   Hints to Keep In Mind .......................................................... 24
   To View the Current Configuration ....................................... 24
   To Perform In-Game Configuring: .......................................... 25
   Configuration Guidelines .................................................... 26
   About the Configuration Hot Key Functions ......................... 27
   Assigning Configurations to Games ................................. 29

4. Using the NVIDIA Stereo Viewer
   About the Stereo Viewer ..................................................... 30
   Functional Overview .......................................................... 30
   Viewable Images ............................................................... 31
   Capturing Images .............................................................. 31
   Viewing Images .................................................................. 32
   Starting the Viewer and Opening an Image File ....................... 32
   Reversing Left and Right Page Flipped Images ....................... 35
   Viewing Page Flipped Images as Anaglyphs ......................... 35
   Setting Resolution and Gamma ........................................... 36
   Viewing a Set of Images as a Slide Show ............................. 36
   Moving the Image Files ...................................................... 38
   Summary of Stereo Viewer Hot Keys ................................... 39

5. Tips and Troubleshooting
Stereo Viewing Tips .............................................. 40
Viewing Practices that Effect Stereo Quality ........................... 40
System and Game Settings that Effect Stereo Quality .............................. 41
Adjustments for Slower Systems .................................. 41
Stereo Game Playing Troubleshooting ................................... 42
  Problem: No Stereo .................................................. 42
  Problem: Image Not Clear ............................................. 43
  Problem: Eyestrain / Headache ........................................ 46
  Problem: No Laser Sight .............................................. 46
Stereo Viewer Troubleshooting ............................................ 47
  Problem: Stereo Image Not Clear ................................. 47
INTRODUCTION TO THE NVIDIA 3D STEREO DRIVER

About the NVIDIA 3D Stereo Driver

The NVIDIA 3D Stereo Driver, when used with compatible hardware, allows full-screen stereo¹ viewing of many Direct3D® or OpenGL® based games². No other stereoscopic driver software is required.

How the Driver Works

When 3D games are played and the driver is enabled, the driver converts the image to 3D stereo and displays it on the screen. You can set up the driver to use either the page flipping or anaglyph method of stereo imaging. With compatible viewing hardware, you’ll see the image with the perception of depth.

Driver Features

Stereo Game Playing

The NVIDIA 3D Stereo Driver comes with a number of controls for use with games.

- **Stereo Separation Adjustment** to suit individual adaptation to stereo viewing.
- **Hot keys** for in-game stereo control.
- **3D Laser Sight** for added realism in first-person shooter games.
- **Stereo Test** process for determining the best screen mode to use.
- **Custom Game Configurations** tailor the stereo process to a wide range of games.

---

¹. For brevity, the term “stereo” in this manual pertains to stereoscopic viewing of images and games.
². Actual stereo quality depends on each game. NVIDIA has rated most games for stereo viewing quality.
Chapter 1
Introduction to the NVIDIA 3D Stereo Driver

Stereo Image Viewing
The NVIDIA 3D Stereo Driver also includes functions for viewing still images in stereo.

- **Stereo Image Capture Utility** takes a screen shot of a stereo game and stores the image on your hard driver.

- **Stereo Viewer Application** takes any JPS or H3D formatted image and displays the stereo image on the screen.

New Features in the 3D Stereo Driver for Detonator XP

This release of the NVIDIA 3D Stereo Driver contains new features not present in the previous release.

Support for Windows 2000 and Windows XP
The NVIDIA 3D Stereo Driver can now be used under Windows 2000 and Windows XP.

New Stereo Game Viewing Features

- **Anaglyph Stereo Viewing**
  “Anaglyph” pertains to the “red/blue” method of creating stereo images. The 3D Stereo driver can now present games in anaglyph stereo for viewing with red/blue 3D glasses. This is especially useful for stereo viewing of games on flat panel LCD monitors, which cannot be used to view page flip stereo. See “Step 2: Set Up the Stereo Type” on page 10.

- **Gamma Control**
  You can now adjust the gamma setting for games. When shutter glasses are used to view page flipped stereo images, the screen appears darker due to each LCD lens turning on and off. With the gamma setting preset, this effect is compensated automatically. See “Adjust the Stereo Gamma Setting” on page 15.

- **Stereo Refresh Rate**
  You now have the option of activating the refresh rate immediately, or only when stereo is enabled during a game. This lets you run the desktop at a lower refresh rate instead of the higher rate required when viewing page flipped stereo. “The New Refresh Rate Behavior” on page 19.

- **Game List Expanded**
  Hundreds of games have been added to the list of games that NVIDIA has evaluated for stereo viewing. Where possible, NVIDIA has preset a number of stereo parameters for these games in order to optimize the 3D stereo experience.
New Stereo Viewer Features

- **Anaglyph Stereo Viewing**
  “Anaglyph” pertains to the “red/blue” method of creating stereo images. The Stereo Viewer can now display JPS files as anaglyph stereo images for viewing with red/blue 3D glasses. See “Viewing Page Flipped Images as Anaglyphs” on page 35.

- **Full-screen Aspect Ratio Maintained**
  When viewing images in full-screen stereo mode, the image is displayed with its original proportions (aspect ratio), and is no longer stretched to fill the screen.

- **New File Handling**
  The Stereo Viewer handles image files differently in this version.
  - **H3D viewing capability**. There is a new capability for viewing H3D formatted files (.h3d). See “Starting the Viewer and Opening an Image File” on page 32.
  - **JPEGs are viewed ‘as is’**. The previous driver version viewed JPEGs the same as JPS images. See “Starting the Viewer and Opening an Image File” on page 32.
  - **JPEG Pair Viewing**. Sets of left/right-view JPEG files can be viewed as page flipped images. “Summary of How to View Files” on page 34.
  - **Improved file search windows**. The file search window under File or View>Slideshow now includes a list of recently opened files or paths. See “Viewing a Set of Images as a Slide Show” on page 36.
CHAPTER 1
Introduction to the NVIDIA 3D Stereo Driver

System Requirements

- 3D Accelerator Card using chipsets from one of the following NVIDIA product families:
  - TNT (including any TNT2 and Vanta products)\(^3\)
  - GeForce (including any GeForce256, GeForce2 and GeForce3 products. GeForce2 Go products require an external monitor that meets the requirements for page flip stereo viewing.)
  - Quadro (including any Quadro2 products)
- Multiscan monitor\(^4\) capable of at least a 100 Hz vertical sync refresh rate at 640x480. (For page flip stereo viewing.)
- Pentium\(^\circ\) 90 MHz or greater, but also refer to specific game requirements.
- 8 MB System Memory, but also refer to specific game requirements.
- Windows\(^\circ\) 2000, Windows\(^\circ\) XP, Windows\(^\circ\) 95, Windows 98, or Windows\(^\circ\) Me, with DirectX\(^\circ\) 8 runtime installed.
- The NVIDIA Detonator\(^\circ\) XP (v22.90 or later) driver must be installed.
- Compatible Stereoscopic Viewing System

A list of compatible viewing products can be found at the NVIDIA website www.nvidia.com, in the 3D Stereo section under driver downloads.

- **Page Flip Stereo** - The NVIDIA 3D Stereo Driver can be used with a number of stereo eyewear models as well as auto-stereoscopic LCD or flat panel displays.

  Some eyewear may require additional configuring of its hardware in order to work properly. The NVIDIA website lists those products that have been tested and verified by NVIDIA to work without requiring additional hardware configuring.

- **Anaglyph Stereo** - The NVIDIA 3D Stereo Driver can be configured for anaglyph stereo viewing. The default orientation and color is left-eye-red and right-eye-blue.

---

3. OpenGL stereo is not supported on the TNT family of products.
4. The 3D Stereo Driver in page flip mode is not designed for LCDs or flat panel displays, with the exception of those that are auto-stereoscopic. For notebooks, an external monitor can be connected and used to view page flip mode stereo.
5. With the 3D Stereo Driver in anaglyph mode, stereo images can be viewed on a flat panel LCD.
Safety - Read Before Using!

⚠️ WARNING!

Do not wear stereo glasses in any situation where unimpaired visual perception is necessary.

Maximizing Safe Use

Under normal conditions, stereo viewing is safe for any duration that you would normally view your PC monitor. However, some people may experience discomfort. To minimize the potential for experiencing visual problems or any adverse symptoms:

- Adjust the monitor refresh rate to the highest possible setting, preferably over 120Hz. Consult your monitor manual for instructions.
- Take the stereo medical test to verify your ability to see stereo images.
- Take regular breaks, at least 5 minutes after every hour of stereo viewing.
- If you experience any of the following symptoms—
  - nausea, dizziness, or queasiness,
  - headache, or eyestrain,
  - blurry vision,
  - double vision that lasts longer than a few seconds,
refer to “Tips and Troubleshooting” on page 40 for suggestions on how to correct the problem.

Do not engage in any potentially hazardous activity (for example, driving a vehicle) until your symptoms have completely gone away.

If symptoms persist, discontinue use and do not resume stereo viewing without discussing your symptoms with a physician.
Epilepsy

⚠️ WARNING!

If you or any member of your family has a history of epilepsy, consult a physician before using computer game products.

A small percentage of the population may experience epileptic seizures when viewing certain types of TV images or video games that contain flashing patterns of light.

- The following people should consult a physician before viewing in stereo:
  - Children under 5 years of age
  - Anyone with a history of epilepsy, or who has a family member with a history of epilepsy
  - Anyone who has ever experienced epileptic seizures or sensory disturbances triggered by flashing light effects.

⚠️ WARNING!

Some light patterns may induce seizures in persons with no prior history of epilepsy. Discontinue stereo use if you experience any of the following symptoms while viewing stereo images:

- Involuntary movements, eye or muscle twitching
- Muscle cramps
- Nausea, dizziness, or queasiness
- Convulsions
- Disorientation, confusion, or loss of awareness of your surroundings

- Do not engage in any potentially hazardous activity (for example, driving a vehicle) until your symptoms have completely gone away.

- Do not resume stereo viewing without discussing the symptoms with your physician.
Using the NVIDIA 3D Stereo Driver

This chapter describes the basic functions of the 3D Stereo Driver Control Panel, and contains the following sections:

- "Getting Started" on page 8
  describes how to install the 3D stereo driver and how to use the control panel to play 3D games in stereo.
- "Game Ratings for Stereo" on page 17
  describes how to determine if your game is suitable for viewing in stereo.
- "Stereo Test and Refresh Rate Setup" on page 18
  describes how to test different color depth, resolution, and refresh rate combinations to determine the best display modes to use when playing games in stereo.
- "3D Stereo Laser Sight" on page 21
  describes how to use the NVIDIA laser sight feature for first-person shooter games.
Perform the following steps to use the NVIDIA 3D Stereo Driver. Each step is explained in greater detail later in this section.

- **Step 1: Install the Drivers and the Stereo Viewing Hardware.**
  Make sure the NVIDIA Detonator XP (v22.90 or later) driver is installed, then install the NVIDIA 3D Stereo Driver.

- **Step 2: Set Up the Stereo Type**
  In the Stereo Properties sheet, click either Page Flipped or Anaglyph stereo type, depending on the type of stereo glasses you have.

- **Step 3: Enable the Stereo Function.**
  In the Stereo Properties sheet, under Stereo Enable Mode, select either Enabled or Enabled by Hot Key, then click Apply. Be sure to take the stereo medical test.

- **Step 4: Set Up Basic Stereo Parameters**
  - **Verify the Hot Keys.**
    Under Display Properties > Stereo Properties, click Additional Properties, then set up or verify setup of the six hot keys—Toggle Stereo On/Off, Less Stereo Separation, More Stereo Separation, Save Image, Increase Gamma, and Decrease Gamma.
  - **Adjust the Stereo Separation.**
    Under Stereo Properties, click Stereo Setup & Test, then in the Monitor Size section of the Stereo Setup & Test page move the bar to your monitor size. In the Stereo Properties sheet, preselect the stereo separation using the Stereo Separation slide bar.
  - **Adjust the Stereo Gamma Setting**
    The default setting should be adequate for all games, but can be adjusted by moving the Stereo Gamma slide bar in the Stereo Properties sheet.

- **Step 5: Play Games in Stereo.**
  Under the Stereo Properties > Stereo Setup & Test sheet, set the stereo refresh rate you want to use for your games, then start the game in full-screen mode and use the hot keys to control the stereo display.
CHAPTER 2  
Using the NVIDIA 3D Stereo Driver

Step 1: Install the Drivers and the Stereo Viewing Hardware

Installation

1. Install the NVIDIA Detonator XP (v22.90 or later) Display Drivers.
   Refer to the installation instructions that came with the new drivers or the display card.

2. Install the NVIDIA 3D Stereo Driver.
   a. Locate the executable stereo file (StereoE.exe) on your hard drive.
   b. Double-click the file to launch the installation program, then follow the instructions to complete the installation.

3. Install the stereo viewing hardware.
   Refer to the documentation that came with your stereo eyewear for instructions.

The Stereo Control Panel

The driver installs a Stereo Properties sheet in the Display Properties Control Panel under Settings > Advanced. To access it:

1. Right click on the Desktop, then choose Properties, or click Start > Settings > Control Panel, then double-click Display from the Control Panel window.

2. Click the Settings tab, then click the Advanced ... button in the Settings sheet.

3. Click the Stereo Properties tab.

Figure 2.1    Stereo Properties Control Panel
**Step 2: Set Up the Stereo Type**

### Choose Page Flipped or Anaglyph Stereo Type

In the Stereo Type section of the Stereo Properties page, choose either Page Flipped or Anaglyph by clicking the corresponding radio button and then clicking the Apply box. See Figure 2.2.

- **Page Flipped**—Choose this type if you have LCD shutter glasses.
- **Anaglyph**—Choose this method if you have “Red/Blue” 3D glasses.

**Step 3: Enable the Stereo Function**

1. Choose the Stereo Enable Mode.

   In the Stereo Properties sheet under Stereo Enable Mode (see Figure 2.2), click either the Enabled or Enabled by Hot Key radio button, then click Apply.

   - **Enabled**: If you select Enabled, stereo turns on as soon as the game starts. Some programs start with simple startup screens that are best viewed with stereo off. The driver attempts to detect this case and waits until the “triangle rich” game starts before turning stereo on.

   Hot keys are functional when Enabled is selected.

   - **Enabled by Hot Key**: If you select Enabled by Hot Key, you must use the hot keys to turn stereo ON or OFF after starting a game. This is useful if you want to view game menus and setup screens in non-stereo mode.


![Figure 2.2 Stereo Enable Setup Controls](image)
2 Take the stereo medical test.
   Each user should take the stereo medical test before playing games in stereo for the first time.
   a Launch the test.
      ◦ When you enable stereo for the first time, the test is launched automatically.
      ◦ To launch the test at any other time, click the Medical Test Image button.
   The Medical Test Image appears on the screen.
   b Follow the instructions on the screen.

   ![Medical Test Image](image)

   **Figure 2.3** Medical Test Image
   ◦ If you do not see the image immediately, allow a few seconds for your eyes to adjust, while changing your viewing distance from the screen.
   ◦ If the page flipping method is used and the image is blurred, verify that the stereo eyewear is functioning.
   The view through the eyewear should darken because each eye view is cycling on and off. If the eyewear does not darken, check the hardware installation and setup.
c Press ESC when you are finished viewing the image.

The Stereo Test Result dialog box asks whether you can see the image in stereo.

![Stereo Test Result dialog box]

**d** Confirm your ability to see the image in stereo.

- If you are able to see the image, click Yes. Stereo is now enabled.
- If you are not able to see the image, click No.

Any further attempts to enable stereo launches the Medical Test Image again.

*Inability to see in stereo might be due to hardware problems or visual problems.*

See “Possible Cause: Eyewear Hardware Not Set Up Properly or Eyewear Driver Support not Installed Properly” on page 44 in the Troubleshooting chapter for help in diagnosing a problem with the eyewear setup or driver installation.

Consult a physician if you suspect a physical problem seeing stereo.
Step 4: Set Up Basic Stereo Parameters

Verify the Hot Keys

Make sure the hot keys are set up so you can control stereo functions during gameplay.

1. From the Stereo Properties sheet, click the Additional Properties ... button.

![Figure 2.4 3D Stereo Driver Hot Key Setup](image)

2. Get familiar with the hot keys. If they are not assigned, set up each hot key as follows:
   
   a. Click in the New Hot Key box, then enter keystrokes corresponding to the desired hot key.
   
   b. Click the Set button corresponding to the hot key function you want to set.

   NVIDIA recommends using the following hot keys:
   
   - Toggle Stereo on/off—Ctrl+T
   - Less Stereo Separation—Ctrl+F3
   - More Stereo Separation—Ctrl+F4
   - Save Image—Alt+F1
   - Increase Gamma—Ctrl+G
   - Decrease Gamma—Alt+G

3. Click OK to return to the Stereo Properties sheet.
Adjust the Stereo Separation

Stereo separation refers to the difference in horizontal position between the right and left images. The greater the stereo separation, the greater the stereo effect. Too much separation, however, can be uncomfortable if your eyes are not adjusted to stereo.

1 Adjust separation according to the diagonal screen dimension of your monitor.

The driver calculates the maximum stereo separation (100%) based on the screen size.

- **a** In the Stereo Properties Control Panel, click the Stereo Setup & Test ... box.

- **b** In the Monitor Size section of the Stereo Setup & test page, move the slide bar to a position corresponding to the diagonal screen dimension of your monitor. (See Do not exceed the size of your monitor, as this can result in too much stereo separation and cause visual problems and headaches.

![Figure 2.5 Selecting the Monitor Size](image)

Monitor Size selection, to establish the maximum stereo separation appropriate for your monitor.

2 Adjust the separation according to your stereo viewing comfort level.

You can set the stereo separation in advance, and also adjust it later during the game.

- **a** In the Stereo Properties sheet, under Stereo Separation (see Figure 2.6), move the slide bar to the expected comfort level, then click OK or Apply.
A recommended starting point is at 30%. You can increase the separation over time as your eyes grow accustomed to stereoscopic viewing.

During gameplay, use the hot keys to adjust the stereo separation.

- Press **Ctrl+F4** (or whichever hot key is defined) to increase stereo separation.
- Press **Ctrl+F3** (or whichever hot key is defined) to decrease stereo separation.

**Adjust the Stereo Gamma Setting**

The On/Off action of LCD shutter glasses (page flipped stereo) darkens the display. To compensate for this effect, the gamma can be adjusted as follows:

1. In the Stereo Gamma Setting section of the Stereo Properties page, move the slide bar to the desired gamma value (0.5–6.00). See Figure 2.6.

   This value is ‘added’ to the gamma that is already set by the game. NVIDIA recommends a value of 1.2.

   One setting should work for all games.

2. Click Apply.

You can also adjust the stereo gamma during a game. This is useful when the game has no gamma adjustment of its own:

- press **Ctrl+G** to increase the gamma (brightness) of the stereo display.
- press **Shift+G** to decrease the gamma (brightness) of the stereo display.
Step 5: Play Games in Stereo

Basic Gameplay

You can now play compatible games in stereo.

1. Determine the suitability of your game for stereo viewing.
   
   See “Viewing the Game Ratings” on page 17.

2. Set the stereo refresh rate for your game.
   
   a. In the Stereo Properties sheet, click the Stereo Test button.
   
   b. Set the color depth and resolution to correspond to the display mode that your game will be set to.
   
   c. Set the refresh rate and then click the Set Rate for All Resolutions button.
      
      Set the refresh rate to 120 Hz if it is available, otherwise use 100 Hz as a minimum.
   
   d. Click the Close button.

   For instructions on how to test the capabilities of your monitor before setting the stereo refresh rate, refer to “Testing Display Combinations” on page 20.

3. Start the 3D game and set to full-screen display mode.

   For setting up the 3D laser on first-person shooter games, see “3D Stereo Laser Sight” on page 21.

4. Use the hot keys to toggle stereo view ON/OFF or to adjust the stereo separation to a comfortable level.
   
   - Press Ctrl+T to turn stereo ON or OFF.
   - Press Ctrl+F4 to increase stereo separation.
   - Press Ctrl+F3 to decrease stereo separation.
   - Press Ctrl+G to increase gamma.
   - Press Alt+G to decrease gamma.

Advanced Features and Help

Refer to other sections of this manual for instructions on how to maximize the stereo display quality:

- “Creating and Modifying Game Configurations” on page 24
  
  provides instructions for advanced users on how to adjust various stereo parameters such as screen depth, convergence, and backplane positioning.

- “Tips and Troubleshooting” on page 40
  
  provides suggestions to help you successfully play games in stereo and maximize the stereo quality of your games.
Game Ratings for Stereo

The level of effective stereo viewing varies from game to game. NVIDIA has evaluated a number of games and provides information to help users determine how well their game will look in stereo.

Understanding the Game Ratings

Ratings for each game are provided in two areas:

- **Stereo Value** - Indicates how much added entertainment value the game has in stereo. Some games are rich in 3D information while others are little more than 2D.

- **Stereo Compatibility** - Indicates how well the game translates to stereo. Some games may contain issues that interfere with good stereo viewing, such as placing objects at depths that are difficult to view.

**Viewing of games that have a low rating can result in adverse symptoms such as headaches and visual problems. It is the user’s responsibility to decide whether to view certain games in stereo based on the information provided.**

Viewing the Game Ratings

To view the Stereo Value and Stereo Compatibility rating for particular games:

1. From the Stereo Properties sheet, click the Game Configuration... button.

2. In the Game Name drop down menu, locate your game, then click the name.

![Figure 2.7 Game Configuration Sheet (Windows 98)](image)

Stereo Value and Compatibility Ratings

The Comments section describes issues in the game that interfere with good stereo viewing.
Stereo Test and Refresh Rate Setup

The Stereo Setup & Test feature allows you to:

- **Test** different color depth, resolution and refresh rate combinations to determine the limitations of your system and the optimum display mode for your games.

- **Set** the stereo refresh rate for your games.

  *This refresh rate overrides the display adapter control panel refresh rate setting. Stereo must be enabled and a mode change performed for the stereo refresh rate to go into effect.*

Controlling the Refresh Rate

Specifying the Refresh Rate

1. From the Stereo Properties sheet, click the Stereo Setup & Test... button.

   The Stereo Setup & Test page appears.

   ![Figure 2.8 Stereo Setup & Test Page](image)

2. Select the color depth using the Bit Depth radio buttons, then move the Resolution slide bar to the desired resolution.

3. Set the refresh rate using the Stereo Refresh Rate slide bar. The best stereo image is achieved at high refresh rates, preferably over 100 Hz.

4. Click the Save Setting button.
The New Refresh Rate Behavior
The display switches to the new refresh rate under the following conditions:

- If the Always Use Refresh Rate check box is checked:
  
The refresh rate is set when you click OK at the dialog box.

- If the Always Use Refresh Rate check box is **not** checked:
  
The new refresh rate is set when the corresponding resolution is set by the game, or if the resolution is set during the display test procedure described below.

  **Note:** There must be a mode change for any refresh rate changes to go into effect. If stereo is disabled, the stereo refresh rate will continue until a change is made to the desktop resolution.
Testing Display Combinations

Basic Instructions

1 Choose a new combination using the Stereo Test Configuration sheet, then click Launch Test Application. (DirectX 8 is required to view the test screen.)
   - A blank screen appears while the refresh rate is measured, then the test screen appears.

   ![Test Screen Image]

   - To change settings while viewing the test screen, press F1.
     A hot key menu appears instructing how to change settings while viewing the test screen. You can then select, view, and save different combinations from this screen.

2 If the image is a clear stereo image, press F6 to save this combination.
   The settings will revert to a “safe” refresh rate, such as 60 Hz, after 15 seconds. Make sure to press F6 before the time runs out if you want to save the current settings.

Suggested Approach

1 Set desired bit depth, then select an optimum refresh rate, such as 120 Hz.
2 Click Set Rate for All Resolutions.
   This forces the selected refresh rate on all resolutions in the test. If the rate is not available, the driver will select the closest available refresh rate for that resolution.
3 Launch the test.
4 Press the (+) key to increase the refresh rate or the (-) key to decrease it as needed to find the highest refresh rate that will pass the test, then press F6 to save this setting.
5 Press the Home/End key to test the next highest/lowest resolution.
3D Stereo Laser Sight

Cross-hair sights in first-person shooter games are usually positioned at screen depth when view in stereo, making it difficult to aim.

To resolve this, NVIDIA provides a selection of 3D “laser” sights that appear on the targeted object. The NVIDIA laser sights work in properly configured first-person shooter games with screen-centered sights.

To use the NVIDIA laser sight:

1. From the Stereo Properties sheet, click the Additional Properties... button.

2. Enable the NVIDIA laser sight.
   - Select On for Configured Games.

3. Select a laser sight design.
   - Click the up or down arrow button to scroll through the selection of sights.

4. Move the Transparency slide bar to adjust the laser transparency—from 0% (solid laser sight) to 100% (almost see-through sight).
   - The recommended setting is at 25%.

5. When finished, click OK or Apply.

The laser sight appears when stereo is turned on during a game. To avoid confusion, disable the sight provided by the game. Refer to the Config Values section under Stereo Properties > Game Configurations > Advanced Settings for any special instructions.
This chapter describes the advanced game configuration feature of the NVIDIA 3D Stereo Driver. It contains these sections:

- “The Purpose of Game Configurations” on page 23 explains the purpose of the game configurations.
- “Creating and Modifying Game Configurations” on page 24 explains how to change the configuration parameters and save the changes.
- “Assigning Configurations to Games” on page 29 explains how to use demo version configurations for the full game version of a game, or visa versa.
The Purpose of Game Configurations

Characteristics of Good Stereo Viewing

Optimum stereo is achieved when the game display consists of the following:

- Meaningful range of depth, or distance between the nearest and farthest objects.
- Nearest objects which are not too close for comfortable viewing.
- Heads up displays (HUDs) which are positioned so as not to interfere with the stereo experience. Ideally, HUDs should be at screen depth.

The NVIDIA 3D Stereo Driver takes certain 3D information contained in the game and uses it to generate the stereo display. Since most games are not designed with stereo in mind, the resulting stereo display quality will vary from game to game. In some cases, the game is not viewable at all in stereo without making adjustments based on observation.

What the NVIDIA 3D Stereo Driver Provides

Preset Configurations

For most games, NVIDIA has established settings that adjust the display to achieve meaningful stereo, based on the needs of each game.

After you launch a game and enable the NVIDIA stereo support, the driver compares the game executable name with its own list. If the driver finds a match, it applies the adjustments to that game to improve the stereo display.

You can view the list of these games in the Stereo Properties > Game Configuration sheet under Game Name.

Hot keys to Change or Create Configurations

Configuring game parameters for stereo is a complex process and should be performed only by persons who are thoroughly familiar with the parameters involved in creating stereo images.

See “Creating and Modifying Game Configurations” on page 24 for instructions on how to:

- Create settings for games which are not listed.
  
  Note: The game will not appear in the Game Name list.

- Change the settings for listed games.

  The NVIDIA provided settings are designed for optimum stereo viewing, and should not require further adjustments. It is possible, though, to change these settings to suit individual tastes.
Creating and Modifying Game Configurations

You can change the stereo parameters for 3D games. When you save the changes, the driver uses the saved settings automatically the next time the game is launched.

Hints to Keep In Mind

- To undo changes that have not been saved, just exit the game.
- To undo changes that have been saved, you must uninstall and then re-install the 3D Stereo Driver.
- To restore original configurations that have been deleted, you must uninstall and then re-install the 3D Stereo Driver.

To View the Current Configuration

1. Find the listed games.
   a. From the Stereo Properties sheet, click Game Configuration.
   b. Scroll through the Game Name list to find your game, then click it.
2. Click the Advanced Settings ... button to open the Advanced Game Configuration sheet.

The Advanced Game Configuration sheet shows the current settings for the game.

Custom configuration data appears here.

Figure 3.1 Advanced Game Configuration sheet
To Perform In-Game Configuring:

1. Set up and get familiar with the Game Configuration Hot Keys.
   
   a. From the Stereo Properties sheet, click the Game Configurations button, then click the Configure Hot Keys button from the Game Configuration sheet.

   ![Game Configuration Hot Keys](image)

   b. If a hot key is not set, click in the New Hot Key box, enter the desired hot-key key strokes, then click the corresponding Set button.

   Avoid assigning hot keys that are needed by your game, or that are already assigned for the basic stereo functions listed under Stereo Properties > Additional Properties.

   c. Make sure the Enable In-Game Configuration box is checked.

   d. Click OK or Apply when finished.

2. Use the hot keys to alter the stereo presentation while viewing the game.

   See “About the Configuration Hot Key Functions” on page 27 for a description of each function, and “Configuration Guidelines” on page 26 for a suggested method of finding the optimum settings for your game.

3. To save the setting, press `Ctl+F7`.

   The driver saves the settings in the registry, and creates a log file in the folder `Nvstereo.log`.

4. To delete all settings and start over, press `Alt+F7`.

   This removes all stereo configuration settings, including the original NVIDIA settings.
Chapter 3

Using the Game Configuration Feature

Configuration Guidelines

Play a game to see how it looks in stereo. Make adjustments using Table 3.1 as a guide.

Table 3.1  Stereo Improvement Suggestions

<table>
<thead>
<tr>
<th>Problem</th>
<th>Suggestion</th>
</tr>
</thead>
<tbody>
<tr>
<td>Objects are too close</td>
<td>Decrease Convergence (Ctl+F5)</td>
</tr>
<tr>
<td>HUD items too close</td>
<td>Increase Screen Depth (Ctl+F10)</td>
</tr>
<tr>
<td>HUD items in the background</td>
<td>Increase Backplane (Alt+F9)</td>
</tr>
<tr>
<td>Side borders blurred, not clear, not visible.</td>
<td>Cycle Frustum Adjust until borders are clear.</td>
</tr>
<tr>
<td>Convergence setting not good for all parts of the game.</td>
<td>Toggle Auto Convergence (Ctl+F8)</td>
</tr>
<tr>
<td>Stereo unclear, but not sure what needs to be adjusted, or where to start.</td>
<td>Suggest Settings (Ctrl+F2)</td>
</tr>
</tbody>
</table>

![Graphical Illustration of Stereo Parameters](image)

Figure 3.3  Graphical Illustration of Stereo Parameters
About the Configuration Hot Key Functions

Table 3.2 lists the functions in the Game Configuration Hot Keys sheet. Use the information in the table as well as the illustration in Figure 3.3 to gain an understanding of each game configuration hot key.

Table 3.2  Stereo Configuration Hot Key Functions

<table>
<thead>
<tr>
<th>Label</th>
<th>Hot Key</th>
<th>Hot Key Action</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle Stereo Default ON</td>
<td>Alt+T</td>
<td>Toggles “Stereo Default ON” on or off.</td>
<td>Stereo Default ON: Stereo is always enabled for configured games. Overrides the Enable Stereo Mode setting. Stereo Default OFF: Stereo enable/disable is controlled by the Enable Stereo Mode setting.</td>
</tr>
<tr>
<td>Cycle Frustum Adjust</td>
<td>Ctl+F11</td>
<td>Cycle through three different frustum settings. First setting: No frustum adjustment. Second setting: Expand the display in the x direction. Third setting: Clear left or right edges of each eye view.</td>
<td>Use to fix problems with the left and right borders.</td>
</tr>
<tr>
<td>Increase Convergence</td>
<td>Ctl+F6</td>
<td>Move objects towards you. Maximum convergence places all objects “in front of” the screen, in user space.</td>
<td>Use along with the Decrease Convergence hot key to achieve a good balance between objects in front of the screen and objects behind the screen.</td>
</tr>
<tr>
<td>Decrease Convergence</td>
<td>Ctl+F5</td>
<td>Move objects away from you. Minimum convergence places all objects “behind” the screen, in CRT space.</td>
<td>Use along with the Increase Convergence hot key to achieve a good balance between objects in front of the screen and objects behind the screen.</td>
</tr>
<tr>
<td>Restore Original Convergence</td>
<td>Alt+F8</td>
<td>Clears any convergence changes made by the Auto Convergence function.</td>
<td>Use to undo changes made by Auto Convergence.</td>
</tr>
<tr>
<td>Toggle Auto Convergence</td>
<td>Ctl+F8</td>
<td>Toggles Auto Convergence ON or OFF. When ON, dynamically adjusts the convergence according to the position of objects in the game.</td>
<td>Use when the range of depth varies quite a bit from scene to scene throughout the game.</td>
</tr>
<tr>
<td>Increase Screen Depth</td>
<td>Ctl+F10</td>
<td>Progressively repositions objects to the screen depth, starting with the closest objects. Moves the most forward plane (RHW &gt; screen) farther back.</td>
<td>Use if the closest objects are positioned inconsistently with the game, such as HUDs.</td>
</tr>
</tbody>
</table>
## Table 3.2  Stereo Configuration Hot Key Functions  (continued)

<table>
<thead>
<tr>
<th>Label</th>
<th>Hot Key</th>
<th>Hot Key Action</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decrease Screen Depth</td>
<td>Ctrl+F9</td>
<td>Reverses the “Increase Screen Depth” action.</td>
<td>Use to maximize the range of depth in front of the screen.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Moves the most forward plane (RHW greater@screen) closer.</td>
<td></td>
</tr>
<tr>
<td>Increase Backplane</td>
<td>Alt+F10</td>
<td>Progressively repositions objects to the screen depth, starting with the farthest objects.</td>
<td>Use if the farthest objects are positioned inconsistently with the rest of the game.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Moves the backplane (RHW lesser@screen) closer to the screen.</td>
<td></td>
</tr>
<tr>
<td>Decrease Backplane</td>
<td>Alt+F9</td>
<td>Reverses the “Increase Backplane” action.</td>
<td>Use to maximize the range of depth behind the screen.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Move backplane (RHW lesser@screen) away from the screen.</td>
<td></td>
</tr>
<tr>
<td>Suggest Settings</td>
<td>Clt+F2</td>
<td>Sets configurations based on data collected during the game.</td>
<td>Use as a starting point to improve undesirable configuration settings.</td>
</tr>
<tr>
<td>Unsuggest Settings</td>
<td>Alt+F2</td>
<td>Reverses any changes made by the Suggest Settings function.</td>
<td></td>
</tr>
<tr>
<td>Write Config.</td>
<td>Ctrl+F7</td>
<td>Saves settings to the registry.</td>
<td>Use when you wish to use the new settings at another time.</td>
</tr>
<tr>
<td>Delete Config.</td>
<td>Alt+F7</td>
<td>Removes the stereo configuration settings from the registry.</td>
<td>CAUTION: This hot key clears all settings, including original NVIDIA provided settings.</td>
</tr>
</tbody>
</table>
Assigning Configurations to Games

If only one version of a game contains configuration settings, such as the demo or full game version, you can apply the settings to another version of the game. For example, if the demo version looks good with the current configuration, the full game version should also look good with the same configuration.

To use a particular configuration for another version of the game, or for another game:

1. Find the listed configuration.
   a. From the Stereo Properties sheet, click Game Configuration.
   b. Scroll through the Game Name list to find the configuration you want to use, then click it.
   c. Click the Advanced Settings ... button to open the Advanced Game Configuration sheet.

2. Select the game to assign to the configuration.
   a. In the Advanced Game Configuration sheet, click the Change... button.
   b. Locate the new game executable file and select it.
   c. Click Open.

The current configuration is now assigned to the chosen game.

Figure 3.4  Assigning Configurations to Unconfigured Games
USING THE NVIDIA STEREO VIEWER

About the Stereo Viewer

Functional Overview

The NVIDIA 3D Stereo Driver comes with a Stereo Viewer application for viewing and manipulating static stereo images. The Stereo Viewer is designed to display images created using the NVIDIA stereo image capture utility, and can also display JPS images from other sources, H3D images, left and right image sets of JPEG images, and anaglyph JPEG images.

The following sections describe the capabilities of the NVIDIA Stereo Viewer:

- “Capturing Images” on page 31
- “Viewing Images” on page 32
- “Setting Resolution and Gamma” on page 36
- “Viewing a Set of Images as a Slide Show” on page 36
- “Moving the Image Files” on page 38
Viewable Images

Table 4.1 lists the types of files that can be viewed with the Stereo Viewer, and provides a brief description of applicable requirements.

<table>
<thead>
<tr>
<th>File Type (extension)</th>
<th>Stereo Type</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPEG Stereo (.jps)</td>
<td>Page Flipped</td>
<td>Created by the Stereo Capture utility from page flipped stereo, or provided by an outside source. Regular JPEGs that consist of a side by side image must be renamed with the .jps extension in order to be viewed as a stereo image.</td>
</tr>
<tr>
<td>JPEG (*l.jpg or *r.jpg))</td>
<td>Page Flipped</td>
<td>Both “left” and “right” image files are viewed as a set. Both filenames must be identical except for the last letter. When one of the files is opened (see “Viewing Images” on page 32) the Stereo Viewer searches for the complementary file in the same directory and opens both files. If a complementary file does not exist in that directory, the first file is opened without any stereoscopic properties.</td>
</tr>
<tr>
<td>H3D (.h3d)</td>
<td>Page Flipped</td>
<td>Must be a true H3D file, and not another file type renamed with the .h3d extension.</td>
</tr>
<tr>
<td>JPEG (.jpg)</td>
<td>Anaglyph</td>
<td>Created by the Stereo Capture utility from anaglyph stereo, or provided by an outside source. JPEG files that are not anaglyphs are opened without any stereoscopic properties.</td>
</tr>
</tbody>
</table>

Capturing Images

The NVIDIA driver includes a stereo image capture function that takes a snapshot of a stereo video or game. It saves page flipped images as a JPS file, and anaglyph stereo images as a JPEG.

To capture a stereo image, press Alt+F1 while playing a game in stereo.

- The hot key for “Save Image” is defined under the Stereo Properties > Additional Properties sheet.
- The driver assigns the image a sequential filename based on the original application, and stores it in the folder Nvstereo.img.
Viewing Images

Starting the Viewer and Opening an Image File

Procedure

1. Start the Stereo Viewer.
   In the Stereo Properties sheet, click the Stereo Viewer box.

2. Load the left and right eye views into the Stereo Viewer
   Option 1: Loading Both Eyes Simultaneously
   a. From the NVIDIA Stereo Viewer window, click File->Open ...
   
   **Hot Key—Ctrl+O**

   b. Locate and choose a stereo file (.jps, .h3d, or .jpg), then click Open.
Both left and right images are displayed in the Viewer window.

- JPS and true H3D files are treated as page flipped stereo images, with the left and right images corresponding to each respective ‘page’.
- If a JPEG file is opened and the filename contains the letter ‘r’ before the extension, the Viewer searches for a similar filename that contains the letter ‘l’ instead of ‘r’. Conversely, if the filename that is opened contains the letter ‘l’ before the extension, the Viewer searches for a similar filename that contains the letter ‘r’ instead of ‘l’. The Viewer then opens both files and treats them as a single page flipped stereo image.
  
  Example filenames: NVIDIA_l.jpg and NVIDIA_r.jpg.
- Other JPEG files are not treated as stereo images, and the left and right images will be identical. However, you can use the stereo viewer to open and view anaglyph JPEGs without the need for paint programs or other graphics viewers.

**Option 2: Load Each Eye Individually**

Pairs of JPEGs that are stereoscopic when viewed alternately (page flipped) can be loaded into each eye of the Viewer individually.

1. Click in one of the ‘eyes’ of the Stereo Viewer window, then choose Load Eye from the menu.
2. Locate the JPEG that corresponds to the ‘eye’ you clicked (left or right), select it, then click Open.
3. Repeat steps 1 and 2 for the other eye view.
4. Click View > Stereo View to see the full-screen stereo display of the image.

**Hot Key—Ctrl+V**

4. When finished viewing, press the ESC key to return to the windowed view.
### Summary of How to View Files

<table>
<thead>
<tr>
<th>Type of Image</th>
<th>How to View</th>
</tr>
</thead>
<tbody>
<tr>
<td>JPS or H3D Image</td>
<td>Just open the file. The Stereo Viewer places the left side of the image in the left eye position and the right side of the image in the right eye position. Sample filename—NVStereo.jps or NVStereo.h3d</td>
</tr>
<tr>
<td>Set of Left and Right JPEGs—Method A</td>
<td>If the filenames for the left and right eyes are identical except for the ‘l’ and ‘r’ designation right before the extension, then open one of the files with the Stereo Viewer. The Viewer opens both files and places the ‘l’ file in the left eye position and the ‘r’ file in the right eye position. Sample filename—NVStereo_l.jpg NVStereo_r.jpg</td>
</tr>
<tr>
<td>Set of Left and Right JPEGs—Method B</td>
<td>You can place any two JPEG files in the left and right eye positions one at a time. For each eye view, right click in the corresponding Viewer window, choose Load Eye from the menu, then select the JPEG file you want to use for that eye view. Sample filename—NVStereoleft.jpg NVStereoright.jpg</td>
</tr>
<tr>
<td>Anaglyph JPEG</td>
<td>Just open the file. Instead of opening another graphics application, you can use the Stereo Viewer as a graphics viewer for JPEGs. Since the left and right eye views are identical, the image does not have stereo properties unless it is an anaglyph. Sample filename—NVStereoanaglyph.jpg</td>
</tr>
</tbody>
</table>
Reversing Left and Right Page Flipped Images

Page flipped images created by the NVIDIA stereo image capture utility will display correctly. Images obtained from other sources, however, may be designed for cross-eyed viewing and will not display correctly. In this case, the left and right images must be switched. To do this:

Open the stereo image, then from the main menu click View->Swap Eyes.

_Hot Key—Ctrl+W_

The left and right images will switch positions. This effects the display of the current image only, not the image file itself.

**Note:** The stereo viewer cannot reverse the display of JPEG images. However, anaglyph displays of JPS or H3D images can be reversed.

Viewing Page Flipped Images as Anaglyphs

To view a JPS file as an anaglyph—

1. Open a JPS file.
2. Switch the display type using any of the following methods:
   - From the main menu, click View->Switch Display Type.
   - Press the hot keys Ctrl+T
   - From the main menu, click View->Option, then in the Display Settings section of the Options page choose Anaglyph and click OK or Apply.

The viewer display changes from page flipped to anaglyph.

3. Click View->Stereo View to view the full-screen anaglyph stereo image.

_Hot Key—Ctrl+V_

**Note:** You can convert the page flipped file to an anaglyph JPEG. While viewing the image in full-screen anaglyph stereo mode, save the image as an anaglyph JPEG using the stereo capture utility (Alt+F1).
Setting Resolution and Gamma

The Stereo Viewer application contains additional viewing functions.

Changing the Display Resolution

1. From the main menu, click View > Options ...
2. Under Display Settings click the arrow button, then choose from the list of available display options, then click OK.

Adjusting the Brightness

To accommodate different monitor and lighting conditions,
- press Ctrl+G to increase the gamma (brightness) of the stereo display.
- press Shift+G to decrease the gamma (brightness) of the stereo display.

Viewing a Set of Images as a Slide Show

You can view a set of JPS, JPG, or H3D images in either automatic or manual sequence.

1. Choose Automatic or Manual viewing:
   a. From the main menu, click View > Options ...
   b. In the Slide Show Settings section, choose either Manual or Automatic.
      - If you choose Automatic, enter the length of time (in seconds) to display each frame.
   c. Click OK.
2 Locate the images to view.

   a From the main menu, click View > Slide Show

   **Hot Key**—Ctrl+S.

   The Slide Show Files window appears.

   ![Figure 4.4 Stereo Viewer Slide Show - Files Selection]

   b To view another directory, either

   - edit the entry in the directory box using the keyboard, or
   - click the drop down arrow and choose from the list of previously accessed directories, or
   - click the Change button, select a different directory where the files are located, then click OK.

3 From the list of files, choose the files to be displayed in the slide show.

4 Click Begin to start the slide show.

   The images will appear in full-screen stereo view.

   If you chose Manual viewing, use the following hot keys to switch images:

   - Next image, exit after the last image: **Space bar**, or **left mouse button**.
   - Next image, repeat the cycle after the last image: **Right arrow**, or **page down key**.
   - Previous image: **Left arrow, page up key**, or **right mouse button**.
Moving the Image Files

Sometimes filenames do not give a good indication of the subject matter, making it difficult to organize files. The Move function allows you to view the image and then immediately move the file to a specified folder.

1. Set up the destination folder.
   a. From the main menu, click View > Options...
   b. From the Miscellaneous Settings section in the Options window, click Change... then use the Browser window to select the destination location for the file(s).

2. Open the stereo image to view it, using File > Open Stereo Image.
   *Hot Key*—Ctrl+O
   Both left and right images will be displayed in the Viewer window.

3. Move the file to the destination folder.
   Click View->Move Image
   *Hot Key*—Ctrl+M
   The file is now stored in the new folder.
# Summary of Stereo Viewer Hot Keys

<table>
<thead>
<tr>
<th>Function</th>
<th>Hot Key</th>
<th>Works in Windowed View</th>
<th>Works in Full-Screen Stereo View.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Stereo Image</td>
<td>Ctrl+O</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Display Image in Stereo</td>
<td>Ctrl+V</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Switch Left and Right Images</td>
<td>Ctrl+W</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Switch Display Type</td>
<td>Ctrl+T</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Increase Gamma</td>
<td>Ctrl+G</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Decrease Gamma</td>
<td>Shift+G</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Move the Image File</td>
<td>Ctrl+M</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Set Up the Slide Show</td>
<td>Ctrl+S</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
Refer to this chapter for ideas on how to maximize the stereo quality, or for help if you have difficulty using the NVIDIA 3D Stereo Driver. This chapter covers the following topics:

- “Stereo Viewing Tips” on page 40 lists suggestions to help maximize the stereo quality of your games.
- “Stereo Game Playing Troubleshooting” on page 42 lists suggestions to help you successfully play games in stereo.
- “Stereo Viewer Troubleshooting” on page 47 list suggestions to help you successfully use the Stereo Viewer.

**Stereo Viewing Tips**

**Viewing Practices that Effect Stereo Quality**

- **Stereo Separation**
  A recommended starting point is 30%, but always adjust the separation to a comfortable level. You can increase it over time as your eyes get used to stereo viewing.

- **Viewing Distance**
  Maintain a distance no closer than 2 to 2.5 feet away from the monitor. Viewing from too close a distance can cause too much strain on your eyes, and reduces stereo quality.

- **Viewing Angle**
  Keep your eyes parallel to the screen. The imaginary line connecting your eyes should be parallel to the horizontal level of the screen.
  The stereo effect is based on side-to-side—or horizontal—displacement of each image. If you tilt your head side-to-side, your eyes no longer see the displacement as
horizontal, and the stereo effect is diminished or even eliminated. While your brain may adjust to this viewing, it must work harder, resulting in eye strain and fatigue.

- **Viewing Time**
  Take regular breaks. As with any time spent looking at a computer screen, it is good practice to give your eyes a rest after a period of time. At a minimum, rest for 5 minutes after every hour of stereo viewing.

- **Viewing with Prescription Glasses**
  If you normally wear glasses when viewing a computer screen, keep them on during stereo viewing. You can put on most stereo eyewear over your regular glasses. The sharper the image on the screen, the better the stereo quality.

### System and Game Settings that Effect Stereo Quality

- **Refresh Rate**
  Set your monitor to the highest refresh rate possible, preferably 120 Hz or higher. The refresh rate for each eye should be higher than 40–60 Hz in order for flicker to be imperceptible. Any perceived flicker degrades the image quality and can lead to eye strain and fatigue.

- **Display Lighting**
  The amount of light reaching each eye is cut in half, and causes the screen to appear darker under stereo viewing. To compensate, be sure to set the gamma setting in the Stereo Properties page to an appropriate level. Adjusting the brightness and contrast settings of your game can also reduce screen persistence and improve stereo quality.

- **Game Cursor / Cross-hair Sights**
  If you are using the NVIDIA 3D laser sights, be sure to turn off the sight that the game provides. The game sight is usually positioned at screen depth, and interferes with useful viewing of the NVIDIA laser sight.

- **Ambient Lighting**
  The intensity of surrounding lighting can effect stereo quality and comfort. Lighting conditions that improve stereo viewing vary from one person to the next, so experiment with brighter or darker room lighting to find what works best for you.

### Adjustments for Slower Systems

- **To Improve Game Performance**
  Since the graphics system must generate twice the number of images, you might notice a decrease in game performance in slower systems. To improve game performance, reduce the monitor resolution for your game.

  *Don’t worry about losing display quality. The display quality at any given resolution is actually enhanced when viewed in stereo.*
Problem: No Stereo

- **Possible Cause: Stereo not enabled**
  - Make sure stereo is enabled.
  
  Under Stereo Properties, click either the Enable or Enable by Hot Key radio button, then click OK or Apply.
  
  Make sure hot keys are set up.
  
  Under Stereo Properties, click the Additional Properties button, then verify the hot keys are defined in the Hot Key Setup section. NVIDIA recommends using `Ctrl+T` for Toggle stereo on/off, `Ctrl+F3` for Less Stereo Separation, `Ctrl+F4` for More Stereo Separation, `Alt+F1` for Save Image, `Ctrl+G` for Increase Gamma, and `Alt+G` for Decrease Gamma.
  
  Turn stereo On.

  While playing the game, press `Ctrl+T` to toggle stereo on and off.

- **Possible Cause: Stereo separation too small**
  - Increase the stereo separation.

  Press `Ctrl+F4` while in the game. Alternately, under Stereo Properties, move the Stereo Separation slide bar to a higher setting—towards Advanced—then click OK or Apply.

- **Possible Cause: Problem with hardware installation**
  - Check to make sure the eyewear is connected and operating. Some eyewear have an on/off switch, or operate on batteries.

  The view through the eyewear should darken when stereo is turned on.

  Refer to the instructions for your stereoscopic viewing hardware.

- **Possible Cause: Problem with driver installation**
  - Check driver documentation.

- **Possible Cause: Game is not in full-screen mode**
  - Set the game to play in full-screen (not windowed) mode.

- **Possible Cause: Game is not configured for Direct3D or OpenGL**
  - Set the game to play using Direct3D or OpenGL hardware rendering. Do not use software rendering.

  Games which do not use Direct3D or OpenGL are not support by the NVIDIA 3D Stereo Driver.
Problem: Image Not Clear

- **Possible Cause: Eyes not adjusted**
  - Your eyes may take some time to adjust to stereo viewing.

- **Possible Cause: Too much stereo separation**
  - Decrease the stereo separation.
  
  Press `Ctrl+F3` while in the game. Alternatively, in the Stereo Properties control panel, move the Stereo Separation slide bar to a lower setting—towards Beginner—then click OK or Apply.

- **Possible Cause: Display mode not optimal**
  
  Adjust the stereo refresh rate.

  1. Under Stereo Properties, click the Stereo Test button, then select the Bit Depth and move the Resolution slide bar to correspond to the game display mode.

  2. Set the Stereo Refresh Rate slide bar to 120 Hz, then press the Launch Test Application button.

  3. If the stereo image looks OK, press `F6`, then press the (+) key to test using a higher refresh rate.

  4. Continue testing until an acceptable display is achieved at the highest refresh rate that your monitor can handle.

- **Possible Cause: Game configuration—no settings exist for any version of the game**

  You can verify this by checking the Game Name list under Stereo Properties > Game Configuration.

  - If your game is not listed, use the hot keys as defined under Stereo Properties > Game Configurations > Configure Hot Keys to create various stereo settings while viewing the game.

  Refer to Table 3.2, “Stereo Configuration Hot Key Functions” on page 27, and Table 3.1, “Stereo Improvement Suggestions” on page 26.

- **Possible Cause: Game configuration—no settings exist for your game version**

  You can verify this by finding your game in the Game Name list under Stereo Properties > Game Configurations, then clicking Advanced Game Configuration.

  - If no ID key exists for your version of the game, refer to “Assigning Configurations to Games” on page 29 for instructions on how to use the configurations of the listed ID for your game.
CHAPTER 5
Tips and Troubleshooting

• Possible Cause: Game configuration—settings exist but are not optimal

If stereo configurations exist for your game, but the stereo image is still not clear, you may need to adjust the configuration settings further.

° Use the hot keys as defined under Stereo Properties > Game Configurations > Configure Hot Keys to adjust various stereo settings while viewing the game.

Refer to Table 3.2, “Stereo Configuration Hot Key Functions” on page 27, and Table 3.1, “Stereo Improvement Suggestions” on page 26.

• Possible Cause: Eyewear Hardware Not Set Up Properly or Eyewear Driver Support not Installed Properly

Eyewear with Left/Right Hardware Switch

Some eyewear must be manually set so that the left and right lenses correspond to the respective left and right screen images. If set incorrectly, stereo images may be difficult to see. To verify whether your stereo eyewear is switching correctly, launch the medical image test.

° If the image consists of a small square hole that is cut out of a larger square—

Your eyewear left/right setup is configured incorrectly. You can confirm this by pressing Ctrl+W. The medical image should now display properly—as a small square in front of a larger square.

You will have to switch your eyewear setting when playing games. Refer to your eyewear documentation for instructions.

° If you cannot see a stereo image—

Press Ctrl+W. If the image can now be seen as a small square in front of the larger square, you will have to switch your eyewear setting when playing games. Refer to your eyewear documentation for instructions.

Eyewear without Left/Right Hardware Switch

Eyewear that does not have a manual switch for left/right orientation is completely controlled by the NVIDIA driver to ensure left/right consistency with the screen image—provided the driver is configured properly. To verify, launch the medical image test.

° If the image consists of a small square hole that is cut out of a larger square—

The driver is configured incorrectly. You can confirm this by pressing Ctrl+W. The medical image should now display properly—as a small square in front of the larger square.

Obtain the latest stereo drivers recommended by the stereo hardware manufacturer, and reinstall the drivers.

° If you cannot see a stereo image—

Press Ctrl+W. If the image can now be seen as a small square in front of the larger square, obtain the latest stereo drivers recommended by the stereo hardware manufacturer, and reinstall the drivers.
• **Possible Cause: Eyewear lenses are the wrong color (anaglyph viewing)**

The default anaglyph configuration is for standard left-eye-red and right-eye-blue glasses. If the colors are reversed or different colors are used in your glasses, customize the anaglyph settings as follows (refer to Figure 5.1):.

1. **Click the Additional Properties ... box, then from the Advanced Stereo Properties page, click the Anaglyph tab.**
2. **In the Anaglyph page, click the drop down menu arrow, then select Custom.**
3. **Click the left or right color box corresponding to the left or right lens of your glasses.**
   - The Color Setup page appears.
4. **Click a Basic Color or a Custom Color, then click OK.**


Problem: Eyestrain / Headache

- **Possible Cause: Too much stereo separation**
  
  Decrease the stereo separation.
  
  Press Ctrl+F3 while in the game. Alternatively, in the Stereo Properties control panel, move the Stereo Separation slide bar to a lower setting—towards Beginner—then click OK or Apply.

- **Possible Cause: Too much flicker**

  Increase the stereo refresh rate.

  1. Under Stereo Properties, click the Stereo Test button, then select the Bit Depth and move the Resolution slide bar to correspond to the mode that your game plays in.

  2. Set the Stereo Refresh Rate slide bar to 120 Hz, then press the Launch Test Application button.

  3. If the stereo image looks OK, press F6, then press the (+) key to test using a higher refresh rate.

  4. Continue testing until an acceptable display is achieved at the highest refresh rate that your monitor can handle.

⚠️ **WARNING!**

If symptoms persist, discontinue viewing in stereo and consult a physician.

Problem: No Laser Sight

- **Possible Cause: Laser sight not enabled**

  Enable the laser sight.

  Under Stereo Properties, click Additional Properties, then select On for Configured Games in the Laser Sight section.

- **Possible Cause: Stereo not enabled**

  Turn stereo On.

  While playing the game, press Ctrl+T to toggle stereo on and off.

- **Possible Cause: Transparency set too high**

  Decrease the laser transparency.

  Under Stereo Properties, click Additional Properties, then move the Transparency slide bar to a lower setting, towards the left.
Stereo Viewer Troubleshooting

Problem: Stereo Image Not Clear

- **Possible Cause: Side by side images are set up for “cross-eyed” viewing**
  - Reverse the images. While viewing the image, press **Ctrl+W**. Alternatively, from the Stereo Viewer window click View > Swap Eyes.

- **Possible Cause: Image is a single image JPEG**
  - Use a JPS image instead.